Firefly and PC GAMESS-related discussion club


 
Learn how to ask questions correctly  
 
 
We are NATO-free zone
 



Re^8: Firefly-8.0.1 is not running on system with Intel MPI-4.1.X...

Pavlo Solntsev
pavlo.solntsev@gmail.com


Dear Siddheshwar.

I attached a script to configure FF. It will create a configuration file in your home folder ~/.firefly.conf with all default configurations.

Place the script into a folder which is in PATH variable and make sure it is executable.
Start using the script by typing

qff2 inputfile

If ~/.firefly.conf is not available script will create it by asking common questions. Before you start make sure you now MPI home directory. The directory with bin and lib directories (32-bit). NBO license information,f if you have it. If you want to use more then one CPU make sure appropriate MPI libraries is installed together with mpirun/mpiexec. In your case IntelMPI.

Depends on your answer, you will get file .sh or .pbs. First is suitable for submission without PBS, while second is suitable for PBS.

You can overwrite default parameters by providing appropriate parameters to the script. See qff2 --help.

Also, you can create new parameters in ~/.firefly.conf by executing qff2 -s or change parameters manually in ~/.firefly.conf by using any text editor.

Also, make sure you have Firefly linked with IntelMPI(!).

Let me know if you have any problem.

Pavel.



On Wed Mar 19 '14 12:28pm, Siddheshwar Chopra wrote
---------------------------------------------------
>Dear Pavel Sir,
>Thanks for encouraging me to go elaborately trough the manual. The points I noted from it:

>1) I need to provide paths to bin and lib folders.. both for 32 bit Intel MPI..

>2) There is a mention of Intel MPI-v3.x in the manual..

>The Problem::

>So I checked on my system and found that it has ONLY Intel MPI- v4.1.x (32 and 64 bit both) installed... SO I added the paths to 32-bit bin and lib folders.. which were inside ..../impi/4.1.0.024/ia32/.
>Did I do right?? But the problem persists giving error "Unable to open input file".. File permissions are also proper.

>Please help.

>Regards,
>
>
>
>On Tue Mar 18 '14 6:35pm, Pavlo Solntsev wrote
>----------------------------------------------
>>Short answer - no.
>>In any case you need a 32-bit libmpi.so library available via $LD_LIBRARY_PATH.

>>Please, read "Linux MPI implementations" section from the manual.
>>
>>
>>Check also "Installing Firefly on an InfiniBand network 64-bit Linux cluster
>>with Intel MPI v. 3.x". You can skip configuration InfiniBand and go directly to IntelMPI setup.

>>Again, read very carefully the manual and use a search. There is also manual - how to setup FF with OpenMPI. Please, search on this forum.

>>Pavel.
>>
>>
>>
>>
>>
>>On Tue Mar 18 '14 12:37pm, Siddheshwar Chopra wrote
>>---------------------------------------------------
>>>Dear Sir,
>>>Please note the configuration of the system on which I have copied the FIREFLY-8.0.1 folder (for Intel MPI version)::
>>>64 Bit Cent OS, and with Intel MPI-4.0.X
>>>Are there Statically linked versions available for Intel MPI ones?

>>>Please help me.

>>>On Sun Mar 16 '14 6:01am, Pavlo Solntsev wrote
>>>----------------------------------------------
>>>>Dear Siddheshwar.

>>>>Please, use the search tool-chain for this site. All you problems were discussed in this forum.
>>>>1) Read the manual, specifically command line section (how to run FF)
>>>>2) Manual also has example of script how to run FF exactly with IntelMPI. do search.
>>>>3) If you can't find answer by using search and/or manual, put EXACT command line or script you use to tun FF.

>>>>If you need a help with scripting i may help.

>>>>Pavlo.
>>>>
>>>>
>>>>
>>>>
>>>>On Sat Mar 15 '14 9:32am, Siddheshwar Chopra wrote
>>>>--------------------------------------------------
>>>>>Dear Sir,
>>>>>I could manage to remove the  "Unable to open input file" error by giving the absolute path to the i/p file.. But now I am struggling with the following persistent error::

>>>>>p4_error: semget failed for setnum: 0

>>>>>Over the internet I came across "cleanipcs". Please help me..I am unable to progress with my work. This error is repeating everytime; not allowing the program to run.

>>>>>Regards,

>>>>>On Sat Mar 15 '14 7:27am, Siddheshwar Chopra wrote
>>>>>--------------------------------------------------
>>>>>>Dear Sir,
>>>>>>Yes I have read the manual.. Could you please point out the mistake Sir. Perhaps it is a very silly mistake. I am new to Linux and need to stay with it for a while. Please help.

>>>>>>Regards,

>>>>>>On Fri Mar 14 '14 10:06pm, Pavlo Solntsev wrote
>>>>>>-----------------------------------------------
>>>>>>>Dear Siddheshwar.

>>>>>>>Did you consult the manual for Firefly's command line options?

>>>>>>>Pavel.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>On Fri Mar 14 '14 3:06pm, Siddheshwar Chopra wrote
>>>>>>>--------------------------------------------------
>>>>>>>>Dear Sir,
>>>>>>>>I am running Firefly801 executable file from unzipped ff801 (relatively located) folder. The system has Intel MPI installed on it. I am running an i/p file xyz.inp located inside ff801/INPUT directory using ::

>>>>>>>>mpirun -np 2 ./firefly801 -r -f -p -i /path/INPUT/xyz.inp
>>>>>>>>But I am getting this error:::

>>>>>>>>FATAL ERROR INITIALIZING FIREFLY! CHECK YOUR COMMAND LINE OPTIONS!

>>>>>>>> ON MASTER NODE, ERROR CODE IS : 0x00000001
>>>>>>>>    Unable to open input file

>>>>>>>>Also please tell how to use -stdext -ex?? What is it used for??

>>>>>>>>Regards,

This message contains the 13 kb attachment
[ qff2_1 ] Configuration script for Firelfy


[ Previous ] [ Next ] [ Index ]           Wed Mar 19 '14 6:54pm
[ Reply ] [ Edit ] [ Delete ]           This message read 532 times