Firefly and PC GAMESS-related discussion club


 
Learn how to ask questions correctly  
 
 
We are NATO-free zone
 



Re^8: Firefly v. 8.0.0 RC 33 build # 7420 is available for testing

Alex Granovsky
gran@classic.chem.msu.su


Dear Firefly users,

this compatibility issue was solved with Firefly v. 8.0.0 RC 34 so I close this thread.

Kind regards,
Alex Granovsky


On Wed Oct 24 '12 1:10pm, Denis Zavelev wrote
---------------------------------------------
>Dear Alex!

>>Is it possible to get remote access to the system for a day or two for debugging?
>I've asked our system administrator about new account in institute's net. If he gets the access, I'll let you know by e-mail. If not... of course, our institute is not far from MSU but I suppose you don't have enough time for this.
>And I'll also try to launch this build on another workstations (with the same Ubuntu version and linux kernel version but with different CPUs).
>
>
>
>>On Wed Oct 24 '12 2:00am, Denis Zavelev wrote
>>---------------------------------------------
>>>Dear Alex!

>>>>it seems there is some incompatibility between FF 8.0.0
>>>>and the Linux kernel version you are using.
>>>Probably so (though I'll try to check it on another PCs with the same Ubuntu and kernel versions).

>>>>My guess is that
>>>>this problem is related to stack allocation code at the very
>>>>beginning of Firefly's execution.
>>>Can this be kernel bug?
>>>Should I try newer or older kernel versions?

>>>>Try adding the following option to the Firefly's command line:
>>>>

./firefly -stkflgs:10 < other options >

>>>Tried it (with and without -nompi). All's absolutely the same: Segmentation fault and absolutely no output.
>>>
>>>
>>>
>>>>>>./configure --prefix=/opt/mpich2-1.5-gcc32 CFLAGS=-m32 CXXFLAGS=-m32 FFLAGS=-m32 FCFLAGS=-m32 --enable-shared

>>>>>My configure string was:
>>>>>./configure --prefix=/home/metalian/mpich2-install --with-arch=LINUX32 --enable-threads --enable-shared CFLAGS=-m32 CXXFLAGS=-m32 FFLAGS=-m32 FCFLAGS=-m32 |& tee c2.txt
>>>>>It works perfectly with 7.1.G (after making 7.1.G working I decided to try 8.0.0rc)

>>>>>>The compiler was gcc version 4.1.2 20071124 (Red Hat 4.1.2-42)
>>>>>>(as C++ and Fortran libraries are not used by Firefly, this is the
>>>>>>only relevant compiler).
>>>>>Ubuntu 12.04 has gcc 4.6.3

>>>>>>I have got a lot of libraries in /opt/mpich2-1.5-gcc32/lib
>>>>>>There was no libmpich.so.3 library so I created it as a symbolic
>>>>>>link to libmpich.so.8  
>>>>>Yes, of course, the same thing (ldd gave me this name to create symlink for, all other libs were also found).

>>>>>>Then I ran Firefly using /opt/mpich2-1.5-gcc32/bin/mpiexec and got it running perfectly.  
>>>>>The only difference is using /home/metalian/mpich2-install but $PATH contains it.

>>>>>>Could it be the case there is some library conflict with
>>>>>>your installation of mpich2?
>>>>>I don't know. How can I find this?

>>>>>>Did you perhaps get some part
>>>>>>of the output in the file or there were no output at all?
>>>>>No output at all.

>>>>>>What is the output of
>>>>>>
>>>>>>./firefly -nompi
>>>>>>

>>>>>>command?
>>>>>Output is the same ('Segmentation fault' and nothing more).

>>>>>Once again, 7.1.G works fine in the same system.
>>>>>
>>>>>
>>>>>>>Just tried to run firefly8.mpich2.ex from rc33 (with the same mpich2-1.5 built from sources with all 32-bit options) and got segmentation fault.
>>>>>>>===================================================================================
>>>>>>>=   BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
>>>>>>>=   EXIT CODE: 139
>>>>>>>=   CLEANING UP REMAINING PROCESSES
>>>>>>>=   YOU CAN IGNORE THE BELOW CLEANUP MESSAGES
>>>>>>>===================================================================================
>>>>>>>YOUR APPLICATION TERMINATED WITH THE EXIT STRING: Segmentation fault (signal 11)

>>>>>>>ldd firefly8.mpich2.ex
>>>>>>>gives:
>>>>>>>     linux-gate.so.1 =>  (0xf774e000)
>>>>>>>     libmpich.so.3 => /home/metalian/mpich2-install/lib/libmpich.so.3 (0xf74eb000)
>>>>>>>     libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf749e000)
>>>>>>>     libopa.so.1 => /home/metalian/mpich2-install/lib/libopa.so.1 (0xf749a000)
>>>>>>>     libmpl.so.1 => /home/metalian/mpich2-install/lib/libmpl.so.1 (0xf7494000)
>>>>>>>     librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf748b000)
>>>>>>>     libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7470000)
>>>>>>>     libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf746b000)
>>>>>>>     libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf72c0000)
>>>>>>>     libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf72a2000)
>>>>>>>     /lib/ld-linux.so.2 (0xf774f000)

>>>>>>>I'm using Ubuntu 12.04 64-bit with all latest updates, kernel version is 3.2.0-32-generic.

>>>>>>>Execution strings used (no difference between results):
>>>>>>>mpiexec -n 2 ./firefly8.mpich2.ex -r -f -p -o $inpfile.out -t scratch -b ./metalian.lib
>>>>>>>mpiexec -n 2 /home/metalian/Quant/ff8rc33_mpich2_linux/firefly8.mpich2.ex -r -f -p -o /home/metalian/Quant/ff8rc33_mpich2_linux/$inpfile.out -t /home/metalian/Quant/ff8rc33_mpich2_linux/scratch  -b /home/metalian/Quant/ff8rc33_mpich2_linux/metalian.lib

>>>>>>>I've also tried to use:
>>>>>>>./firefly8.mpich2.ex -f -p -o inptest.out -ex . -t scratch -p4pg procgrp
>>>>>>>In this case I'm getting only "Segmentation fault" message and nothing more.

>>>>>>>System is based upon AMD Athlon(tm) 64 X2 Dual Core Processor 6000+.


[ Previous ] [ Next ] [ Index ]           Wed Nov 7 '12 2:09pm
[ Reply ] [ Edit ] [ Delete ]           This message read 752 times