Firefly and PC GAMESS-related discussion club



Learn how to ask questions correctly


Re^7: Running Firefly in Intel Core 2 Duo Scientific Linux -- Error TID 1037 caught signal 11, exiting. Dump of registers follows..

Alexei Popov
alexei.a.popov@gmail.com


Hello,

it seems the Scientific Linux is version 5.4,
and the kernel is actually 2.6.18-164.2.1.el5xen, isn't it?

In brief, this is a known problem of Xen and some para-virtualized
Linux kernels... they do not take care of being absolutely consistent.

Boot to standard kernel, and the problem will go away.

Regards,
Alexei



On Mon Mar 29 '10 5:51am, Edward Castillo wrote
-----------------------------------------------
>Hi

>1)   Intel Core2/ Linux  Firefly version running under Linux.
> Running on Intel CPU:  Brand ID  0, Family  6, Model  15, Stepping  2
> CPU Brand String    :  Intel(R) Core(TM)2 CPU     4400  @ 2.00GHz
> CPU Features        : CMOV, MMX, SSE, SSE2, SSE3, SSSE3, MWAIT, EM64T
> Data cache size     :  L1 32 KB, L2 2048 KB, L3     0 KB

>  I use MPICH for MPI implementation.

>2) I haven't tested it to a regular kernel.

>Thanks,

>Edward

>On Sun Mar 14 '10 0:06am, Alex Granovsky wrote
>----------------------------------------------
>>Hi,

>>just a couple of questions:

>>1. What are the exact binaries (CPU, linking type, MPI implementation)  you need?

>>2. Did you check if firefly works normally under regular kernel, rather that under the xen specific one?

>>Regards,
>>Alex Granovsky
>>
>>
>>
>>On Sat Mar 13 '10 12:08pm, Edward Castillo wrote
>>------------------------------------------------
>>>Hi,

>>>    I'm sorry for the late reply. the kernel version is 2.6.28-128.1..1.el5xen. Yes please can you send to me the precompiled binaries for this? Thank you so much! =)

>>>Regards,

>>>Edward

>>>On Mon Mar 8 '10 0:07am, Alex Granovsky wrote
>>>---------------------------------------------
>>>>Hi,

>>>>Is that 32-bit kernel? What is the exact kernel version?

>>>>This sigsegv is the known problem with some Linux kernels
>>>>that do not set the GDT limit in GDTR properly. The only
>>>>workaround is to disable call64 option in the input file.

>>>>This can be done e.g. using Firefly's preprocessing features -
>>>>e.g., you can include the template file with your favorite presets.

>>>>Alternatively, I can provide you by the precompiled binaries
>>>>with this option turned off by default.

>>>>Regards,
>>>>Alex
>>>>
>>>>
>>>>
>>>>
>>>>On Sat Mar 6 '10 5:37am, Edward Castillo wrote
>>>>----------------------------------------------
>>>>>Hi,

>>>>>   Thank you very much! It worked! =)

>>>>>Regards,
>>>>>Edward

>>>>>On Thu Mar 4 '10 7:37pm, Alex Granovsky wrote
>>>>>---------------------------------------------
>>>>>>Hi,

>>>>>>please check if setting $smp call64=0 $end cures the problem.
>>>>>>
>>>>>>Regards,
>>>>>>Alex Granovsky
>>>>>>
>>>>>>
>>>>>>On Thu Mar 4 '10 1:05pm, Edward Castillo wrote
>>>>>>----------------------------------------------
>>>>>>>Hi, I tried installing Firefly to an Intel Core 2 Duo in my Scientific Linux.  I tested the BENCH01.INP and some other files but I am receiving errors. I am just running in one pc.

>>>>>>>I used ./firefly -r -f -p -i BENCH01.INP -o BENCH01.OUT -ex /scratch/ -t /tmp/

>>>>>>>where I placed the pcgp2p.ex, p4stuff.ex and fastdiag.ex in /scratch.

>>>>>>>Below is the error

>>>>>>>TID 1037 caught signal 11, exiting.

>>>>>>>Dump of registers follows

>>>>>>>eax :: 0x00001003, edx :: 0x00001003
>>>>>>>ecx :: 0x00001c00, ebx :: 0x00000000
>>>>>>>esi :: 0x00000004, edi :: 0x00000001
>>>>>>>ebp :: 0x00000003, esp :: 0xbfa7d5a4
>>>>>>>eip :: 0x1081e190, eflags :: 0x00010206

>>>>>>>cs  :: 0x0073
>>>>>>>ds  :: 0x007b
>>>>>>>es  :: 0x007b
>>>>>>>ss  :: 0x007b
>>>>>>>fs  :: 0x00d7
>>>>>>>gs  :: 0x0000
>>>>>>>
>>>>>>>
>>>>>>>The output file ended in the input cards.

>>>>>>>Can anyone pls help me?


[ Previous ] [ Next ] [ Index ]           Thu Apr 1 '10 12:51pm
[ Reply ] [ Edit ] [ Delete ]           This message read 853 times