Firefly and PC GAMESS-related discussion club

Learn how to ask questions correctly  
We are NATO-free zone

Re^4: Runing Firefly8


Dear Pavel.

Thank you, was a syntax error.
Openmpi compile and install.
But when I run FF error:
asp @ linux-ldmm: ~ / bin/8lin> ./firefly8.openmpi14.ex
./firefly8.openmpi14.ex: error while loading shared libraries: cannot open shared object file: No such file or directory

On Sun Nov 11 '12 7:50am, Solntsev Pasha wrote
>Dear Serg.

>I will try to help you. First of all, FF is 32-bit application and you can't change this. The general situation is follow. Usually applications have some dependences to library files. It means, that application calls some functions from library files during normal run. Thus, FF also needs some external libraries to run parallel code. There is one BIG problem. For 32-bit applications the libraries also should be 32-bit. Since, 64-bit OS becomes more and more popular installed by default libraries on clusters are also 64-bit. To run FF you need install 32-bit libraries. If you have suitable 32-bit version of OpenMPI in your repository, go ahead and install it via normal way (apt-get, yum etc..). Otherwise, you need to compile the library by yourself. Again, we are talking about compilation of the library. No changes will be applied to FF executable file.

>Based on your post, i see one syntax mistake. It should be -m32, but not -M32. I would recommend you just copy and paste that string from the pdf file Alex pointed out. Please, read very carefully that pdf file and if you have problem with configure stage post exact output from terminal and config.log file. You can also find a lot of information in WWW, since this is not related to FF.

>Copy and paste string below:
>./configure --prefix=$HOME/bin/openmpi CFLAGS=-m32 CXXFLAGS=-m32 FFLAGS=-m32 FCFLAGS=-m32

>Don't put extra spaces into string.

>Hope this help.

>On Sat Nov 10 '12 5:20am, Serg wrote
>>Tried to install as described in the file. It is impossible.
>>Command failed
>>  . / configure -- prefix = / home / user / bin / openmpi CFLAGS =-m32 CXXFLAGS =-m32 FFLAGS =-m32 FCFLAGS =-M32
>>Writes See `config.log 'for more details.
>>In `config.log 'nothing is clear.
>>Will create a 64-bit Firefly?

>>On Fri Nov 9 '12 12:37pm, Alex Granovsky wrote

>>>you need to install 32-bit OpenMPI.


>>>Kind regards,
>>>Alex Granovsky
>>>On Fri Nov 9 '12 7:00am, Serg wrote
>>>>Trying to run Firefly 8 under Linux (64-bit) gives the following error
>>>>firefly8.openmpi14.ex: error while loading shared libraries: wrong ELF class: ELFCLASS64
>>>>or we need to run another file them there are several.
>>>>Openmpi 1.4.5 installed.

[ Previous ] [ Next ] [ Index ]           Sun Nov 11 '12 9:24am
[ Reply ] [ Edit ] [ Delete ]           This message read 961 times