Firefly and PC GAMESS-related discussion club

Learn how to ask questions correctly  
We are NATO-free zone

Re^9: Firefly-8.0.1 is not running on system with Intel MPI-4.1.X...

Siddheshwar Chopra

Dear Pavel Sir,
I am using the appropriate Intel MPI version of firefly.. But it is 4.1.024 one.. I really doubt that there is any issue with the configuring Sir. I am also using the absolute paths everywhere and with proper file permissions... But the same error returns:: "Unable to open input file"..
I am actually upset with this error. By common sense it feels like Firefly is facing file permission or file locating issues... Please throw more light on this error. If there was an error associated to libraries etc., shouldn't it have shown "unable to use shared libraries etc"?? But why does it tell me "unable to  open input file"?

Alex Sir I am really missing a manual for Firefly which consists of TILL NOW obtained errors and their tried and tested solutions.. It would be really great to compile such a manual.

Please help Sir.

On Thu Mar 20 '14 6:24pm, Pavlo Solntsev wrote
>You don't need to run ~/.firefly.conf file. It is a configuration file but not a script.

>delete ~/.firelfy.conf (just in case) or use -s argument for qff2 (see qff2 --help)

>1) run "qff2 basename.inp". Where basename.inp is your input file.
>At this step, ~/.firefly.conf script will be created. Also, you will see file or basename.pbs in your current folder. They are scripts. Only one file will be generated or basename.pbs.
>2) run firelfy by typing "bash" or "qsub basename.pbs"

>Next time just type qff2 inputfile. Since you already have ~/.firefly.conf script will not ask you for information to create it again. If you want to change some default parameters you don't need to regenerate ~/.firelfy.conf. Instead, you can edit ~/,firelfy.conf manually.
>see qff2 --help for more options.

>On Thu Mar 20 '14 3:04pm, Siddheshwar Chopra wrote
>>Dear Pavel Sir,
>>I am thankful to you for providing the qff2 script. I have successfully generated a "firefly.conf" file. But what should I do next? I am running "qff2 firefly.conf" now, but it is again and again asking me the details which were already provided to create firefly.conf. What I have to do next Sir?

>>On Wed Mar 19 '14 6:54pm, Pavlo Solntsev wrote
>>>Dear Siddheshwar.

>>>I attached a script to configure FF. It will create a configuration file in your home folder ~/.firefly.conf with all default configurations.

>>>Place the script into a folder which is in PATH variable and make sure it is executable.
>>>Start using the script by typing

>>>qff2 inputfile

>>>If ~/.firefly.conf is not available script will create it by asking common questions. Before you start make sure you now MPI home directory. The directory with bin and lib directories (32-bit). NBO license information,f if you have it. If you want to use more then one CPU make sure appropriate MPI libraries is installed together with mpirun/mpiexec. In your case IntelMPI.

>>>Depends on your answer, you will get file .sh or .pbs. First is suitable for submission without PBS, while second is suitable for PBS.

>>>You can overwrite default parameters by providing appropriate parameters to the script. See qff2 --help.

>>>Also, you can create new parameters in ~/.firefly.conf by executing qff2 -s or change parameters manually in ~/.firefly.conf by using any text editor.

>>>Also, make sure you have Firefly linked with IntelMPI(!).

>>>Let me know if you have any problem.

>>>On Wed Mar 19 '14 12:28pm, Siddheshwar Chopra wrote
>>>>Dear Pavel Sir,
>>>>Thanks for encouraging me to go elaborately trough the manual. The points I noted from it:

>>>>1) I need to provide paths to bin and lib folders.. both for 32 bit Intel MPI..

>>>>2) There is a mention of Intel MPI-v3.x in the manual..

>>>>The Problem::

>>>>So I checked on my system and found that it has ONLY Intel MPI- v4.1.x (32 and 64 bit both) installed... SO I added the paths to 32-bit bin and lib folders.. which were inside ..../impi/
>>>>Did I do right?? But the problem persists giving error "Unable to open input file".. File permissions are also proper.

>>>>Please help.

>>>>On Tue Mar 18 '14 6:35pm, Pavlo Solntsev wrote
>>>>>Short answer - no.
>>>>>In any case you need a 32-bit library available via $LD_LIBRARY_PATH.

>>>>>Please, read "Linux MPI implementations" section from the manual.
>>>>>Check also "Installing Firefly on an InfiniBand network 64-bit Linux cluster
>>>>>with Intel MPI v. 3.x". You can skip configuration InfiniBand and go directly to IntelMPI setup.

>>>>>Again, read very carefully the manual and use a search. There is also manual - how to setup FF with OpenMPI. Please, search on this forum.

>>>>>On Tue Mar 18 '14 12:37pm, Siddheshwar Chopra wrote
>>>>>>Dear Sir,
>>>>>>Please note the configuration of the system on which I have copied the FIREFLY-8.0.1 folder (for Intel MPI version)::
>>>>>>64 Bit Cent OS, and with Intel MPI-4.0.X
>>>>>>Are there Statically linked versions available for Intel MPI ones?

>>>>>>Please help me.

>>>>>>On Sun Mar 16 '14 6:01am, Pavlo Solntsev wrote
>>>>>>>Dear Siddheshwar.

>>>>>>>Please, use the search tool-chain for this site. All you problems were discussed in this forum.
>>>>>>>1) Read the manual, specifically command line section (how to run FF)
>>>>>>>2) Manual also has example of script how to run FF exactly with IntelMPI. do search.
>>>>>>>3) If you can't find answer by using search and/or manual, put EXACT command line or script you use to tun FF.

>>>>>>>If you need a help with scripting i may help.

>>>>>>>On Sat Mar 15 '14 9:32am, Siddheshwar Chopra wrote
>>>>>>>>Dear Sir,
>>>>>>>>I could manage to remove the  "Unable to open input file" error by giving the absolute path to the i/p file.. But now I am struggling with the following persistent error::

>>>>>>>>p4_error: semget failed for setnum: 0

>>>>>>>>Over the internet I came across "cleanipcs". Please help me..I am unable to progress with my work. This error is repeating everytime; not allowing the program to run.


>>>>>>>>On Sat Mar 15 '14 7:27am, Siddheshwar Chopra wrote
>>>>>>>>>Dear Sir,
>>>>>>>>>Yes I have read the manual.. Could you please point out the mistake Sir. Perhaps it is a very silly mistake. I am new to Linux and need to stay with it for a while. Please help.


>>>>>>>>>On Fri Mar 14 '14 10:06pm, Pavlo Solntsev wrote
>>>>>>>>>>Dear Siddheshwar.

>>>>>>>>>>Did you consult the manual for Firefly's command line options?

>>>>>>>>>>On Fri Mar 14 '14 3:06pm, Siddheshwar Chopra wrote
>>>>>>>>>>>Dear Sir,
>>>>>>>>>>>I am running Firefly801 executable file from unzipped ff801 (relatively located) folder. The system has Intel MPI installed on it. I am running an i/p file xyz.inp located inside ff801/INPUT directory using ::

>>>>>>>>>>>mpirun -np 2 ./firefly801 -r -f -p -i /path/INPUT/xyz.inp
>>>>>>>>>>>But I am getting this error:::


>>>>>>>>>>> ON MASTER NODE, ERROR CODE IS : 0x00000001
>>>>>>>>>>>    Unable to open input file

>>>>>>>>>>>Also please tell how to use -stdext -ex?? What is it used for??


[ Previous ] [ Next ] [ Index ]           Sat Mar 22 '14 9:30am
[ Reply ] [ Edit ] [ Delete ]           This message read 807 times