Firefly and PC GAMESS-related discussion club


 
Learn how to ask questions correctly  
 
 
We are NATO-free zone
 



Re: linux installation error

Thomas Pijper
thomaspijper@hotmail.com


Dear James,

To the best of my knowledge, you need to use a 32-bit version of OpenMPI instead of a 64-bit version .


Kind regards,
Thom



On Wed Apr 1 '15 1:32am, James Mao wrote
----------------------------------------
>Dear friends,

>I used to run firefly in windows, and now is trying to put it into a linux machine. I believed I downloaded the correct version:

>"Firefly version 8.1.0 download links, Linux/OpenMPI v. 1.6.x, dynamically linked version"

>While I tried to run firefly, I got the following error message:

>./firefly810: error while loading shared libraries: libmpi.so.1: wrong ELF class: ELFCLASS64

>I have OpenMPI 1.6-3.1.2 (on opensuse 12.x) installed and it works well with other programs. It was built as 64-bit and the compatibility for 32-bit is turned on.

>Any suggestion what is wrong?

>BTW: is the pre-compiled source code available to download? Could not find it in the download page.

>Thank you all very much!

>J.M.

>


[ Previous ] [ Next ] [ Index ]           Wed Apr 1 '15 1:27pm
[ Reply ] [ Edit ] [ Delete ]           This message read 328 times