Firefly and PC GAMESS-related discussion club

Learn how to ask questions correctly

Re^4: Hardware problem

Alex Granovsky

Dear Gena,

could be an OpenMPI issue. We had some issues with OpenMPI 1.2
series some time ago and they are documented on the Forum AFAIR.

Would you like to test Firefly 8.0.0 beta with OpenMPI 1.4.x or 1.5.x?
Please contact me directly if you are interested.

As to second part of your question, it should not be
a problem to increase the overall number of allowed AOs.
However, MP2 energy/gradient code and conventional SCF
with integral packing would require some additional changes.
Most likely, we will increase the number of allowed AOs while
keeping these two parts of Firefly limited by current limit of 4095 AOs.

Kind regards,
Alex Granovsky

On Mon May 9 '11 10:16pm, Gena wrote
>Dear Alex,

>i use OpenMPI version of Firefly 7.1.F. I configured openmpi 1.2.9 using command ./configure --with-memory-manager=none CFLAGS=-m32 CXXFLAGS=-m32 FFLAGS=-m32 FCFLAGS=-m32. I don't remember why, because it was long time ago, when i first installed firefly; but with other parameters firefly didn't work with openmpi. So i found these options on openmpi's site through google, and for many months firefly worked fine. I've installed new Ubuntu recently (because of my audiocard problems with previous versions primarily, as i use firefly on my home desktop), but for the first few days there were no problems.
>Actually, I have one more question, concerning Firefly features: if the maximum of 4035 basis functions limitation will be kept in new 8th version? Because in this particular system i can't choose def-TZVP basis, for example, due to this limitation; and on the other hand due to the symmetry i don't think the calculation time will be so unreasonable...
>On Mon May 9 '11 9:30pm, Alex Granovsky wrote
>>Hi Gena,

>>are you using plain mpich version of Firefly?
>>This could be an MPI implementation issue.
>>Also, a sample typical file causing problems could be informative.

>>Kind regards,
>>Alex Granovsky
>>On Mon May 9 '11 4:54pm, Gena wrote
>>>On Sat May 7 '11 1:48pm, Gena wrote
>>>>I've got some nasty problem recently: during geometry optimization of a molecule, i noticed, that beginning from certain step firefly just stopped modifying .out file and also temporary DFTGRID, DICTNRY etc. files. After killing the job i recognized, that from then the same problem started to reproduce from the very beginning step, hanging after few iterations or even after reading guess orbitals. I'm using Phenom II 1055T processor on Ububntu 11.04 X64. I've found out, that there is no such problem if only 4 of 6 cores are used. (Until recent time there were no problems with 6 cores). I assume this is hardware problem, since it's reproducible on different kernels and i didn't do any significant changes in OS software, on which firefly worked fine few days ago.
>>>>What i do not understand - is that my system passes all possible stress tests (LinX, Prime95 etc.), and when firefly calculations hangs up, OS itself works normally - just there is no changes in .out file.
>>>>Could anyone help me with any suggestions where to seek the root of problem? Or, maybe, is there specific options in firefly execution, those will clear the situation?

>>>Upd. For some reason, there is no such problem, if i run two different tasks with firefly, one consuming 2 cores and one 4 cores, thus loading my CPU completely...

[ Previous ] [ Next ] [ Index ]           Tue May 10 '11 0:01am
[ Reply ] [ Edit ] [ Delete ]           This message read 881 times