Firefly and PC GAMESS-related discussion club



Learn how to ask questions correctly


Re: problem when runing Firefly in parelell (mpich2)

Slava
svkohut@yahoo.com


On Sun Jan 30 '11 3:29pm, Slava wrote
-------------------------------------
>Dear folks!
>I'm newbie at computing with Firefly, so the answer to my question may seem very easy to you) However... I want to run Firefly in paralell. I've already downloaded Firefly 7.1 G for Linux, mpich2 interface. I read the manual about working with Firefly (mpich) (in Manuals section on this site), downloaded and installed necessary libraries (32 bit!), configured the working directory as it's written in the manual. When I tried to execute inp-file with the command  "mpiexec -n 2 ./firefly -i 2D.inp /node0 /node1" or "mpirun -np 2 ./firefly -i 2D.inp /node0 /node1", I got the following error message "error while loading shared libraries: libmpich.so.1.1: cannot open shared object file: No such file or directory". This lib is indeed absent in usr/lib32, but newer version is available (libmpich.so.1.2). Does Firefly (mpich2) work by default with mpich2 v.1.1 or it can be fixed by editing approptiate config file?

>Thanks in advance,
>Slava  

P.S. problem SOLVED! You have just to create symlink for libmpich.so.1.2 and name it libmpich.so.1.1. Very easy sollution and it works fine for me. Maybe, this post will be helpful for novice FF users.


[ Previous ] [ Next ] [ Index ]           Sun Jan 30 '11 6:49pm
[ Reply ] [ Edit ] [ Delete ]           This message read 2748 times