Firefly and PC GAMESS-related discussion club



Learn how to ask questions correctly


Re^4: More advanced problem – p2p fails

Vyacheslav
kreme_vg@chemy.kolasc.net.ru


Hi!
Alex, we used your options for tests without appreciable improvement. We have destroyed our cluster, reinstall OS on all nodes and have again created the cluster – results are the same…
Below I apply some results for MP2 input, taken from Performance page (in %):

Cores     xdlb=t     bind=t   blkdlb=0      nbiolb=1         sndbuf=256_rcvbuf=256

8         100          100        100              100                     100
16        166.7      178.7     165.4         169.6                  176.3
24        127.4      121.8     121.8         127.6                  124.1
32        182.4      165.4     181.1         186.1                  194.2
40                                                                                  194.2

Options p2p=.t.  xdlb=.t. are presented in all inputs. Influence of sndbuf and rcvbuf values variation from 64 up to 1024 is insignificant.
Have you any ideas? We haven't. Unfortunately, we have no any IT expert - both of us only chemists.

Sorry, I've overlooked to mention, our HPC version is intended for Server 2008 Standard, not for Server 2008 R2.

------------------------------------------------------------------------
On Sat Mar 27 '10 10:08pm, Alex Granovsky wrote
-----------------------------------------------
>Hi,

>sorry for the delayed reply.

>It your HPC solution is based on Win2K8 R2, (note not R1),
>you may be affected by the same core parking problem, as Windows 7 users.

Note we do not test it under Win2K8 R2...

>Second, just adding

>

 $p2p p2p=.t. $end

>does not automatically enables dynamic load balancing. Use at least

>

 $p2p p2p=.t. dlb=.t. $end

>or

>

 $p2p p2p=.t. xdlb=.t. $end

>You can also give a try to more advanced communication-related p2p options like:

>

 $p2p 
     p2p=.t. xdlb=.t. 

! to bind to interface 
     bind=.t. 
! to use non-blocked I/O for DLB 
     blkdlb=0 
! to use polling instead of blocking waiting for DLB event
     nbiolb=1 
! to set larger TCP window sizes (in Kbytes) 
! for send and receive buffers.
     sndbuf=256 rcvbuf=256
 $end                          

>Finally, use "-daf 2" command line option to reduce communication's
>overhead.

>regards,
>Alex Granovsky



[ Previous ] [ Next ] [ Index ]           Tue Mar 30 '10 1:45pm
[ Reply ] [ Edit ] [ Delete ]           This message read 715 times