Firefly and PC GAMESS-related discussion club

Learn how to ask questions correctly

Re: Problem running FIREFLY on a 64-bit MPICH2 environment

Jim Kress

You must create the 32 bit MPICH2 libraries on your 64 bit nodes and they must be in the PATH and the LD_LIBRARY_PATH environment variables.

Firefly will only work with the 32 bit libraries.


On Sat Jun 19 '10 4:00am, Reinaldo Pis Diez wrote
>Dear folks,

>I'm moving the parallel environment in our linux cluster from MPICH to MPICH2 (1.2.1p1 version).
>I've also installed the MPICH2 version of FIREFLY in some of the nodes just for checking. FIREFLY is version 7.1.G, build number 5618.
>The O.S. in the cluster is CentOS, 4.6 in some 32-bit machines and 5.4 in the remaining 64-bit nodes.
>MPICH2 was compiled with the native gcc compiler on every machine, thus I have both 32- and 64-bit libraries, depending on the node.
>When I run FIREFLY in the 32-bit nodes it's all right, the performance is really good. But, when I run FIREFLY in the 64-bit nodes I got the message "error while loading shared libraries: wrong ELF class: ELFCLASS64" and the job dies. I suspect there is some problem with the libraries against FIREFLY was compiled (32-bit perhaps?), but I'm far from being an expert, so I'd appreciate very much any help/hint to solve the problem. I've tried to add the -arch flag to mpiexec but it is not implemented yet.
>Thanks in advance.


[ Previous ] [ Next ] [ Index ]           Sat Jun 19 '10 5:41am
[ Reply ] [ Edit ] [ Delete ]           This message read 1300 times